Déploiement de la version PHP 5.6.8 beta sur les serveurs des pages perso de FREE.

Mis à jour le

  1. Déploiement de la version PHP 5.6.8 beta

    Aujourd’hui, mercredi 22 juillet à 15 h 40  min, Lionel Bernardi, administrateur des pages perso de FREE, a annoncé que la version PHP 5.6.8 beta est déployée sur tous les serveurs des pages perso de FREE.

    Pour activer le php 5.6 (beta), il faut ajouter la directive suivante dans le fichier « .htaccess » :

    <IfDefine Free>
    php56 1
    </IfDefine>
    

    Bien sûr, cette directive remplace la directive actuelle qui est

    <IfDefine Free>
    php 1
    </IfDefine>
    
    Depuis WordPress 4.4 les versions originales fonctionnent parfaitement avec cette directive, il n’est donc plus besoin d’installer une version adaptée à PHP 5.1.3.

    Ainsi prend fin la longue série d’adaptation de WordPress aux pages perso de FREE !

    Les informations techniques relatives à ce déploiement sont disponibles sur le site les.pages.perso.chez.free, ici : Migration des serveurs des Pages Perso de Free vers PHP 5.6.8

  2. Télécharger le fichier « .htaccess » optimisé et sécurisé pour PHP 5.6.8

    Un nouveau fichier « .htaccess » est disponible en téléchargement depuis le 4 janvier 2016, il permet :

    • d’activer PHP 5.6.8 sur les pages perso
    • de modifier les permaliens sans créer d’erreur 500 sur les pages perso de FREE en désactivant les rewrite rule de WordPress sur FREE selon les conseils de nobody@nobody.fr.invalid sur le forum USENET officiel de support des pages perso de FREE
    • de sécuriser WordPress et d’optimiser son chargement selon les conseils de Al du site les.pages.perso.chez.free

    cliquer sur le bouton ci-dessous :

    .htaccess sécurisé pour PHP 5.6.8 <---- « .htaccess »

    Voir le code du fichier « .htaccess » sécurisé et optimisé

  3. Comment migrer depuis une version adaptée pour PHP 5.1.3 ?

    1. Modifier le fichier « .htaccess »

      de façon à activer PHP 5.6.8 comment indiqué ci-dessus.
      Les versions que j’ai adaptées à PHP 5.1.3 fonctionnent sous toutes les versions de PHP supérieures à 5.1.2 et donc WordPress continuera de fonctionner normalement.

    2. Faire une sauvegarde complète :

      Avant de se lancer dans une mise à jour il est très important de faire auparavant une sauvegarde complète de la base de données (BDD) et du FTP comme indiqué dans le CODEX WordPress : Détails de mise à jour.

    3. Mettre à jour vers la version originale de WordPress

      Il est préférable d’effectuer cette première mise à jour vers une version originale manuellement via FTP. En effet, la mise à jour manuelle est la plus sûre de toutes et c’est celle que vous devrez faire en dernier recours en cas de problème sur votre site.

      La mise à jour automatique est parfaitement possible à condition de supprimer du fichier « wp-config.php » les lignes indiquées dans la section d) ci-après.

    4. Activer les mises à jour automatiques

      Pour bénéficier des mises à jour automatiques ainsi que de l’installation de thèmes et d’extensions depuis le tableau de bord de WordPress, vous devez supprimer les lignes suivantes dans le fichier « wp-config.php » :

      /** Désactive les mises à jour automatiques de WordPress */
      define( 'AUTOMATIC_UPDATER_DISABLED', true );
      
      /** Désactive l’Installation d'Extensions et de Thèmes */
      define('DISALLOW_FILE_MODS',true);
      
      Les mises à jour de sécurité (version mineures, par exemple 4.2.x) seront effectuées automatiquement dans la nuit. La mise à jour des versions majeures (par exemple 4.x) restera, elle, à votre charge et pourra s’effectuer depuis le tableau de bord (ou via FTP).

      Pour de plus amples renseignement, voir CODEX : Configurer les Mises à Jour Automatiques en Coulisses

    5. Créer des répertoires techniques à la racine des pages perso :

      • Le répertoire « tmp »

        où sont enregistrés les fichiers temporaires par défaut;

      • le répertoire « sessions »

        les sessions permettent tout du long de la visite d’un internaute sur le site, de conserver des informations de façon transparente.

    6. Activer les widgets par défaut (si besoin) :

      Pour que les widgets par défauts de WordPress soient visibles, vous pouvez éditer le plugin automatique « /wp-content/mu-plugins/no-wp-widgets.php » ou alors le supprimer.

    7. (Optionnel) Utiliser la bibliothèque « gettext » pour réduire la consommation de mémoire PHP

      Les pages perso disposant désormais de 64 Mo de mémoire PHP, cette modification est optionnelle; elle permet néanmoins d’alléger la charge du serveur mutualisé, ce qui est fortement apprécié par les administrateurs réseaux puisque facilitant la cohabitation entre les différents site web présents sur le serveur mutualisé.

      Sur mon site, la mémoire PHP consommée est passé de 20,9 Mo à 16,87 Mo, soit une réduction de 4,03 Mo (environ 19,3 % en moins).

        Elle est identique à celle décrite dans les pages d’adaptation de WordPress à PHP 5.1.3 des pages perso de FREE. Cette modification s’effectue selon les deux étapes suivantes :

        • Première étape : ajouter le fichier « /wp-includes/pomo/native.php »

          Vous pouvez télécharger le fichier « native.php » en cliquant sur le bouton ci-dessous. Il est inclus dans le dossier « wp-includes.zip ». Il suffit de dézipper ce dossier « wp-includes » puis de le placer à la racine du site via FTP (avec Filezilla, par exemple) pour que le fichier « native.php » soit automatiquement ajouté au bon endroit.

          wp-includes.zip<----- pack gettext /wp-includes

          Ce fichier « native.php » est un hack wordpress créé par linushoppe qui permet d’utiliser la bibliothèque « gettext » du projet GNU d’internationalisation (traduction) lorsque celle-ci est déjà implantée au niveau du serveur (elle l’est sur les pages perso de FREE), ce qui permet d’économiser 4 Mo de mémoire PHP.

          Le fichier « /wp-includes/pomo/native.php » restera toujours présent sur le serveur même après les mises à jour automatiques de WordPress (à moins que vous ne le supprimiez vous même via FTP).
        • Deuxième étape : modifier le fichier « /wp-config.php » situé à la racine du site.

          Il suffit d’ajouter au fichier « /wp-config.php » les lignes suivantes qui permettent d’inclure le fichier « /wp-includes/pomo/native.php  »

          /* Utilisation de gettext pour l'internationalisation */
          require( ABSPATH . '/wp-includes/pomo/native.php');
          
  4. Restrictions à l’usage de WordPress sur les pages perso

    1. Modification des permaliens (chez FREE)

      La modification des permaliens a toujours créé une erreur 500 sur les pages perso (excepté pour les versions que j’avais adapté à PHP 5.1.3 qui n’en n’en créaient plus du tout).

      Le nouveau fichier « .htaccess » disponible en téléchargement depuis le 4 janvier 2016 empêche WordPress de créer une erreur 500 sur les pages perso.

      Désormais, avec ce nouveau fichier « .htaccess », il n’y a plus d’erreurs 500 sur les pages perso de FREE lors de la modification des permaliens.

    2. Attention, les permaliens chez FREE doivent toujours être personnalisés avec le réglage Structure personnalisée et précédé de /index.php/ comme par exemple /index.php/%postname%/ pour afficher le nom de l’article.
      De plus amples renseignements sont donnés dans le CODEX ici : Les marqueurs de structure
  5. Accès sortants

    A l’heure actuelle, seuls les accès sortant permettant d’effectuer les mises à jour automatiques de WordPress sont autorisés. Tous les autres accès sortants sont bloqués.
    Dans l’avenir, Lionel Bernardi, ouvrira d’autres accès sortant. Il faudra effectuer la demande sur un fil de discussion dédié dans le forum USENET offciel de support des pages perso.

  • Sécuriser la page d’administration de WordPress

    A la suite de nombreuses attaques vers les pages d’administration des sites WordPress et Joomlaa, Lionel Bernardi (administrateur des pages perso de FREE) a installé un script qui fixe des règles pour limiter ces requêtes et interdire l’accès aux adresses IP qui tentent de se connecter trop souvent à ces pages d’administration. Toutefois, ce script, parfois trop sensible, a interdit à certains blogueurs l’accès à leur propre site depuis leur box internet. Si tel est votre cas, vous devez contacter le forum USENET des pages perso pour que Lionel Bernardi, l’admin des pages perso, déblackliste votre adresse IP.

    Pour éviter ce problème, il est très fortement conseillé de bunkériser l’accès à l’administration de WordPress. Comment bunkériser l’admin de WordPresss ?
  • Que faire en cas de problème ?

    1. Contacter le forum USENET officiel de support des pages perso de FREE

      En cas de problème lors de l’installation de WordPress sur les pages perso de FREE, vous pouvez demander de l’aide sur le forum USENET officiel de support des pages perso de FREE. Des bénévoles vous expliqueront tout en détail.

      Ce forum USENET n’est pas accessible depuis un navigateur internet. C’est en réalité un « groupe de discussion » (comme ceux usités par les universitaires).

      Il suffit de s’abonner à « proxad.free.services.pagesperso » après avoir installé un logiciel de News comme par exemple :

    2. Contacter le forum officiel de support de WordPress

      Pour un problème lié à WordPress lui-même, vous pouvez vous adresser aux forums supports de WordPress :

  • Si vous avez trouvé une faute d’orthographe, informez-nous en sélectionnant le texte et en appuyant sur Ctrl + Enter

    70 réflexions au sujet de « Déploiement de la version PHP 5.6.8 beta sur les serveurs des pages perso de FREE. »

    1. Oui comment ne pas te remercier pour ton travail ? Merci !

      J’ai une question concernant le hack /pomo/native.php .

      Avec 64M, je suppose qu’il n’est plus nécessaire ?

      Si je décide de le faire pour économiser les 5M de mémoire, cela aura-t-il un effet négatif et/ou inutile sur mon site ?

      Merci

      1. Bonjour,
        Perso, je l’ai conservé. Comme j’avais déjà installé une version adaptée à PHP 5.1.3, il m’a suffit de modifier le fichier « /wp-config.php ».

        Il est vrai qu’avec 64 Mo de mémoire PHP, rien ne nous contraint à faire cette optimisation, c’est un choix. Perso, j’ai un un gain de 4,03 Mo de mémoire PHP, passant de 20,9 Mo à 16,87 Mo ce qui sur un hébergement mutualisé permet aussi d’alléger la charge du serveur.

        Sur le site lui-même je n’ai pas observé d’impact, les traductions sont toujours faites et le site me semble un peu plus rapide.

        Comme tu poses la question, j’ai ajouté une section Utiliser la bibliothèque « gettext » pour réduire la consommation de mémoire PHP pour les personnes intéressées.
        Cordialement.

    2. Bonsoir,

      Je viens d’installer WordPress 4.2.3 sur ma page perso.

      Cela fonctionne bien en dehors d’un malencontreux bug : le menu latéral bugue complètement avec des superpositions d’icônes et des disparitions de menu nécessitant un rafraîchissement. Quelqu’un a rencontré le même problème ?

      1. Bonjour,
        Pas de problème de ce genre sur mon site. Qu’en dit le forum support de WordPress ?
        A mon avis, il s’agit d’un problème de javascript.

        Désactive tous les plugins, pour trouver l’origine du problème. Si le problème est résolu, il suffit de réactiver les plugins un par un pour trouver le fautif.
        Sinon, active le thème par défaut, pour vérifier que ce ne soit pas le thème qui crée ce problème.

        1. Bonjour,

          J’ai effectué tous les tests que tu préconisais : le bug persistait.

          Par hasard j’ai testé sous firefox : le bug a disparu.

          J’ai désinstallé la version dev de Chrome pour installer la version stable : le bug a disparu.

          Résultat : petite incompatibilité avec la version Chrome 45 Dev.

          Merci pour les conseils.

    3. Bonsoir,

      Tout se passait jusqu’à ce que je fasse la MAJ automatique des plugin anti spam et daily cleaner optimizer.

      Je ne sais si cela vient de ça ou des serveurs Free qui ont planté mais je n’ai plus accès à rien :-(

      J’ai une erreur 500 – erreur interne du serveur

      J’ai désactiver les plugins en renommant le fichier pluginsX mais cela ne résous pas le souci.

      J’étais contente car la MAj vers la version 4.2.3 s’était très bien déroulée.

      Une idée du problème ?

      Merci d’avance.

      Karine

      1. Bonjour,
        Non pas d’idées, ces mêmes plugins fonctionnent parfaitement sur mon site.

        Souvent, les erreurs 500 sont dues à des « rewrite rules » que WordPress écrit dans le fichier « .htaccess » et que FREE interdit. Il suffit de les supprimer pour corriger cette erreur.

        1. Bonsoir Luciole,

          J’ai vérifié et je n’ai rien d’autres dans le htaccess. J’avoue que je ne comprends pas trop d’où peut venir le souci.

          Comme je le dit j’ai désactivé tous les plugins…

          Je continue d’essayer de chercher d’où vient l’erreur…

          1. Certainement que la directive

            <IfDefine Free>
            php56 1
            </IfDefine>

            a été mal copié dans le fichier « .htaccess »
            Avez-vous supprimé l’ancienne directive ?

          2. Re,

            Je viens de réinstaller la mise à jour et maintenant autre message d’erreur :

            Warning: Cannot modify header information – headers already sent by (output started at /var/www/sdb/b/7/motelsavinien/wp-config.php:1) in /var/www/sdb/b/7/motelsavinien/wp-includes/pluggable.php on line 1196

            Je pense que je vais repasser à la 4.1.5 ça ira mieux :-(

                1. Bonsoir,
                  Je n’ai aucune idée du pourquoi, j’ai encore migré vers PHP 5.6.8 aujourd’hui un de mes sites de test qui était sous PHP 5.1.3 sur les pages perso sans aucun problème.
                  Contactez les forums supports officiels de WordPress et celui des pages perso.
                  Cordialement

                  1. Bonsoir Luciole,

                    Mon htaccess contient ceci :

                    # Spécification des jeux de caractères des documents (ajoutez les extensions que vous utilisez)
                    AddCharset utf-8 .css .xml .po .php .js
                    
                    # activation php5 (free.fr)
                    <ifDefine Free>
                     PHP56 1
                    </ifDefine>
                    
                    # Protection du fichier .htaccess
                    <Files .htaccess>
                    Order Allow,Deny
                    Deny from all
                    </Files>
                    
                    # Protection du fichier wp-config.php
                    <files wp-config.php>
                    order allow,deny
                    deny from all
                    </files>
                    
                    # Désactivation de l'affichage des répertoires
                    Options All -Indexes
                    

                    Je ne comprends pas apparemment ça me met une erreur 500 quand j’active un à un les plugins. Est-ce qu’on a droit à quelques plugins quand même ou il faut tout supprimer ?

                    Je vais tente la version 4.1.6 et si ça plante je repasse avec la 4.1.5…

                    Bonne soirée

                    1. Bonsoir,
                      Le fichier « .htaccess » est normal.
                      Avec php 5.6.8, on a droit a beaucoup de plugins puisque l’on dispose de 64 Mo de mémoire PHP. Mais pour une mise à jour, il faut toujours les désactiver.
                      Avez-vous créé les dossiers « tmp » et « sessions » ?

    4. Bonsoir,
      apres avoir tenté une installation de wordpress 4.2.3( après suppression dbb et l’ensembles des repertoires et fichiers de site web ) et bien mis le .htaccess pour php 5.6.8, je me retrouve avec cette erreur :
      Warning: Cannot modify header information – headers already sent by…./wp-login.php on line 425
      auriez-vous une idée ?

      1. Bonjour,
        Je suppose que vous avez écrit dbb pour base de données (BDD)
        Pourquoi avez-vous supprimé la BDD ?
        Pourquoi avez-vous supprimé l’ensemble des fichiers ?
        J’ai pourtant rappelé la procédure de mise à jour via FTP.

        J’espère pour vous que vous avez une sauvegarde, sinon, vous avez perdu votre site !

        1. je voulais repartir à zero..donc pas de problème mais j’ai quand meme une sauvegarde.
          Par contre, j’ai toujours ce message d’erreur, aucune idée?

          1. Bonsoir,
            Si vous voulez repartir à zéro, allez-y franco de port en supprimant complètement le FTP et en vidant la BDD.
            Puis réinstallez WordPress de façon classique, sans oublier de créer les dossier « tmp » et « sessions » à la racine du site.

    5. Bonjour,
      suivant aussi les pages perso chez Free, j’avais eu vent de l’information aussi de cette bonne nouvelle enfin PHP5.6.
      Juste une question, après une mise à jour sans problème, seul hic, les vidéos ne fonctionnent pas avec la fonction native de WP, en ne mettant que l’url, on n’a pas le lecteur vidéo, obligé de mettre une extension.
      Autre souci, cherche un plugin pour avoir un sitemaps.xml, celui de Arne Brachhold buggue, avez vous un plugin pour le sitemaps.xml? Si oui lequel ? Merci
      ps: pas d’option pour être notifier si on a une réponse à son commentaire?

      1. La version étant encore beta, elle n’est pas définitive. Il faut faire remonter tous les bugs constatés sur le forum USENET officiel des pages perso de façon à ce que tous les bénévoles puissent tester et que Lionel Bernardi, administrateur puisse corriger.

        Pour le sitemap, j’utilise Xml Sitemap Generator qui fonctionne très bien et est très simple.

        Non, je n’ai pas installé de plugin permettant de gérer les commentaires. Il est vrai que c’est pratique mais je trouvais qu’ils consommaient trop de mémoire PHP. Maintenant, avec 64 Mo de mémoire PHP, je l’envisagerai peut-être, vous en connaissez un de bien ?

        1. Bonjour,

          Comme je vous le disais, je suis depuis un moment le site Les pages perso chez Free.fr, je sais que l’on doit signaler les bugs, mais c’est un newsgroup il faut soit configurer son logiciel de messagerie ou installer un logiciel de news, juste pour ça, je ne vais pas me prendre la tête, je ne serais pas le seul à constater le problème et puis c’est une version bêta, il y aura vraiment un problème si c’est pareil en version officiel.
          Je sais c’est pas bien, c’est perso, c’est égoïste, oui c’est vrai, c’est tout moi.

          Xml Sitemap Generator le plugin n’a plus de mise à jour depuis 14 Aout 2013, presque 2 ans, je redoute toujours une faille de sécurité sur un vieux plugin.
          C’est pour ça que je ne faisais plus rien sur mon site chez Free, vieille de WP, risque de faille trop important, travailler pour tout perdre, une sauvegarde ne garantie à 100% de récupérer un site, il peut avoir un bug pendant la procédure de sauvegarde.
          Mais bon si le plugin fonctionne chez vous, je le prends, on verra bien.

          – j’aime bien le plugin Comment Mail peut être un peu lourd, mais la mémoire allouée est encore de la place, juste 38% occupé.
          Merci

          1. Bonsoir,
            Configurer un logiciel de news n’est pas plus compliqué que d’installer WordPress et de toutes façons, si un jour votre page perso a un problème, vous devrez aller sur ce forum USENET.

            Je vous rassure de suite, vous n’êtes pas du tout en question, vous n’avez rien de particulier, vous n’êtes pas plus égoïste que la très grande majorité des autres beta-testeurs qui n’aura pas non plus envie de se prendre la tête, c’est banal (normal).

            De par mon expérience sur le forum de support de WordPress, la très grande majorité des usagers se comporte non pas en contributeur, mais en consommateur d’entraide. De ce fait, si le bug n’est pas signalé, il y restera (Perso, je ne me sers jamais des vidéos, alors je ne vais pas non plus me prendre la tête pour un problème qui ne me concerne pas).

            Des consommateurs qui attendent des bénévoles un service gratuit (satisfait ou remboursé [sic]). de la même qualité qu’un support payant (et sans avoir à débourser un seul centime, cela va de soi), sans jamais contribuer eux-même à l’entraide et au partage (Pourquoi faire gratuitement le boulot (sic) des bénévoles ?), sans dire merci (tout leur est du, ils sont nés comme ça) et le plus souvent en insultant les bénévoles quand ces derniers ne connaissent pas la solution à leur problème (« non, mais allo quoi, je rêve ! »).

            Dans le partage, chacun participe librement à la hauteur de ses maigres connaissances et surtout de son temps libre, personne n’a jamais demandé plus que cela.

            Heureusement, il reste la solution d’installer son site sur un hébergeur payant avec un support payant (Il y a des choses qui ne s’achètent pas, pour tous le reste il y a MasterCard) et qui demande simplement à ses utilisateurs de continuer à consommer (à la base, le métier de TF1, c’est d’aider Coca-Cola, à vendre son produit). Et si l’on refuse absolument de payer quoi que ce soit, on peut encore utiliser un service gratuit de blog comme wordpress.com.

            Avoir un site web sur les pages perso de FREE, du fait même des nombreuses restrictions techniques, nécessite de mettre les mains dans le cambouis, dans le code source, dans PHP, HTML, CSS et MySQL (donc, prise de tête). Cela demande aussi de configurer un logiciel de news pour accéder au forum support officiel (c’est dingue, faut vraiment tout faire soi-même !).

            Le plus simple est de bien choisir son hébergeur en fonction de ses besoins et capacités techniques (Bien choisir son hébergement WordPress), il est fort probable que FREE ne soit pas l’hébergeur qu’il vous faille (Il a FREE, il a tout compris !).

            Bonne soirée.

              p.s :

            • Merci pour le plugin, je vais y réfléchir.
            • Pour le problème de la soi-disant non mise à jour du plugin, je vous laisse lire la discussion suivante où vous pourrez entendre Lumière de Lune, admin du forum français de support de WordPress, ici : Plugin non mis à jour : compatibilité et/ou sécurité ?
            1. Bonjour,

              j’utilise ma page perso depuis que je suis chez Free, donc depuis 15 ans, jamais je n’ai eu besoin d’aller sur le forum d’usenet , je me débrouille tout seul.
              Malgré tout hier j’ai configuré mon Thunderbird, mais pas rouvé le sujet pour cette mise à jour de PHP5.6

              Pour le plugin, je n’ai pas parlé de compatibilité mais de sécurité, ne pas confondre les 2.
              – Un plugin à jour, compatible peut avoir une faille de sécurité.
              – Un plugin non à jour, peut être compatible mais si il a des failles de sécurité, elles seront plus connues que sur un plugin récent par les hackers.

              J’ai installé le plugin que vous conseillez, je vous le disiez si vous avez bien lu mon message :
              « Mais bon si le plugin fonctionne chez vous, je le prends, on verra bien. »

              J’ai lu des messages de Lumière de lune, je sais que cette personne installe des sites pour les autres c’est son métier, sur son site, elle descend le plugin WordPress SEO by Yoast, cela la regarde, j’ai utilisé ce plugin, il est très bien, il faut juste savoir l’utiliser, ne pas prendre pour argent comptant ces indications.
              Lumière de Lune n’est pas pour moi une référence.

              Free me convient très bien, juste écrire des petits articles, voir mettre une vidéo, pas besoin d’un hébergeur payant.
              Vous m’avez très mal cerné, depuis 18 ans que je suis sur internet, je ne suis que sur des hébergeurs gratuits.

              1. Bonjour,
                Pour retrouver un sujet, il faut vous désabonner du groupe et vous réabonner avec plus de message, essayez 1500 ou plus si jamais. Pour le retrouver il suffit de trier et de retrouver les messages signé Lionel Bernardi daté du 17 juin et intitulé [PHP-5.6/Alpha testing] Rapport de bugs.

                Justement, Lumière de Lune ne confond pas sécurité et compatibilité, les autres intervenants confondent, mais je ne ferai pas ici de discussion à ce sujet, vous pouvez relancer la discussion que je vous ai indiqué, ce sera mieux approprié.

                Attention, je ne conseille pas plus ce plugin qu’un autre, c’est celui qui me convient car je n’écris pas souvent de nouveaux articles, donc je l’active juste au besoin. Si j’écrivais quotidiennement des articles, j’en choisirai un d’entièrement automatique. Quant au SEO, je ne m’en sers pas et mon site est très fréquenté par les fumeurs sans avoir besoin de SEO (faut dire qu’il est seul dans sa niche).

                Pour les vidéos, avez-vous essayé le code EMBED comme indiqué dans le CODEX ? Embeds

                Je n’ai pas cherché à vous cerner ni à vous blesser, mais simplement à expliquer à tous ceux qui liront ces lignes que ce n’est pas parce que je partage que je fais aussi le support, il y a deux forums dédiés existant, c’est là-bas qu’il faut aller. Mon site n’est pas un forum d’entraide, ce n’est pas sa vocation.
                Bonne soirée.

                1. Bonjour,

                  – J’ai trouvé un autre sujet mais vu comment les gens répondent sur ce forum, j’ai tout supprimé, une personne signale des petits bugs comme il est demandé, des personnes, qui ne sont pas de Free, répondent sans tenir compte que la personne utilisent ailleurs les plugins, pour eux les problèmes viennent des plugins ou de WP pas de Free.

                  – C’est vous qui parlait de comptabilité, je n’en ai pas parlé dans mon premier message, je disais juste que le plugin n’était pas à jour, je ne parle que de sécurité là, déjà qu’une plugin à jour à au moins une faille de sécurité alors un plugin non à jour doit en avoir encore plus.

                  Pour moi la sécurité à 100% n’existe pas, un site à toujours au moins une faille, même si tout est à jour.

                  Je ne regarde pas la ligne Compatibilité quand je prend un plugin, tous les plugins sont compatibles WordPress sinon il ne sont pas fait pour WP, j’ai toujours fait la différence entre compatibilité et sécurité.
                  Je n’ai pas compris votre message, je n’ai pas fait amalgame entre les 2 mots.

                  Je ne suis pas présent sur le forum wordpress-fr.net, je n’aime pas les forums et je n’ai jamais eu de question à poser, si j’ai un souci, les sites sont là pour aider, souvent un article donne la solution ou un simple commentaire.

                  Je n’ai pas demandé de support, juste le nom d’un plugin sitemap.xml , vous m’avez répondu, la discussion aurait du s’arrêter là.

                  1. « J’ai trouvé un autre sujet mais vu comment les gens répondent sur ce forum, j’ai tout supprimé »

                    C’est un forum où il y a beaucoup d’administrateurs d’autres CMS et qui ne ratent jamais une occasion de dire tout le mal qu’ils pensent de WordPress.
                    Vous avez cru bien faire en donnant votre opinion sur l’origine du problème (chmod), mais malheureusement cela a soulevé un débat hors-sujet alors qu’il s’avère que le problème vient des accès sortants interdits chez FREE depuis déjà quelques années.
                    Si vous trouvez un autre bug, le plus simple est de le signaler et puis c’est tout, les pros s’ils sont intéressés, conjectureront sur son origine.

                    « C’est vous qui parlait de comptabilité, je n’en ai pas parlé dans mon premier message, je disais juste que le plugin n’était pas à jour, je ne parle que de sécurité là »

                    Je vous ai répondu sur la mise à jour, je n’ai pas parlé de compatibilité, j’ai simplement mis en lien une discussion dont le titre cause de compatibilité, mais je n’en ai pas parlé.

                    « déjà qu’une plugin à jour à au moins une faille de sécurité alors un plugin non à jour doit en avoir encore plus. »

                    Non, il n’y a aucune relation de cause à effet entre l’âge du plugin et sa sécurité. Ce sont deux notions étrangères l’une à l’autre.
                    La vulnérabilité est liée aux interactions du plugin avec la base de données de WordPress, pas à son âge. C’est ce que fait le plugin qui le rend plus ou moins vulnérable, rien d’autre.

                    Bonne journée.

        2. Salut, j’utilise Facebook comments plugin : ( http://peadig.com/wordpress-plugins/facebook-comments/ ), il consomme pas trop de memoire car tout est decentralisé chez facebook.

          J’ai écris un article sur les quelques plugin leger que j’ai pu tester ici et la pour ameliorer mon WordPress sur les pagesperso free, tu peux consulter ici -> http://portalproject.pic.free.fr/index.php/heberger-son-site-worpress-sur-un-espace-perso-free/

    6. Bonjour,

      Un grand MERCI pour votre travail.

      Je n’arrive pas à croire qu’on ne puisse pas enlever index.php des URL… il doit bien y avoir une solution… un rewrite quelque part ou autre chose…
      Je ne suis pas développeuse mais quand même c’est les êtres humains qui programment les machines pas l’inverse !
      Je voudrais que quelqu’un me dise :
      – « Bien sûr c’est possible, pas facile mais possible. Voilà la marche à suivre »

        1. Bonjour Luciole,

          Comme vous me l’avez suggéré j’ai posé la question sur le forum USENET officiel. Pour l’instant il ne semble pas y avoir de réponse.
          J’ai fini par installer mon site avec l’adresse index.php et cela ne présente finalement pas d’inconvénient.
          D’une part les internautes ne font pas attention à l’URL d’autre part en matière de référencement ce qui importe c’est l’adresse du site, le mien est depuis 16 ans à la même adresse en .free, j’aurais perdu très gros à changer d’adresse !! et toujours et encore le contenu.
          Par contre reste le problème de la vitesse de chargement.
          J’ai installé sur mon site vos plugins :
          – Use jQuery CDN
          – Use jQuery Cloudflare
          Je ne sais pas s’il est utile d’installer les 2.

          Les résultats sur Gtmetrix sont passés de E(57%) et D(67%) à D(61%) et D(68%)

          Pour ce qu’il en est de :
          – Use jQuery jsDelivr cela a déclenché une erreur fatale au moment de l’installation (je l’ai supprimé)

          Je donne ici l’adresse de tous vos plugins que peut-être par modestie vous n’indiquez pas :
          https://profiles.wordpress.org/luciole135/#content-plugins

          Pour la compression Gzip j’ai eu beau lire la page :
          http://les.pages.perso.chez.free.fr/activer-la-compression-sur-les-pages-perso.io
          Je pense qu’elle s’adresse à des personnes qui écrivent leur code.
          Y aurait-il une solution pour les sites créés avec WordPress ?

          Un grand Merci pour votre travail.

          1. Bonjour,
            Merci pour les compliments.
            Pour les plugins Use-jquery-XXX, il ne faut en installer qu’un seul puisque cela charge des scripts jQuery depuis un Cloud et donc, il est inutile de les charger deux fois. J’ai fait en sorte que ces plugins ne puissent pas être installés simultanément (la deuxième installation doit normalement échouer), c’est étrange que vous ayez réussi à en activer deux en même temps.

            Pour la compression GZIP, j’ai écrit un tuto qui est bien plus accessible au néophyte que celui des pages.perso.chez.free.fr car destiné spécialement aux utilisateurs de WordPress. Il est ici Activer la compression Gzip facilement sans aucun plugin sur WordPress !.

            1. Vous avez raison en fait j’ai constaté que Use jQuery Cloudflare empêchait l’affichage d’un audio sur une de mes pages, je l’ai donc désinstallé. J’ai seulement Use jQuery CDN.

              Pour Gzip je regarde votre tuto et je reviens vous dire.

              Merci !

    7. Bonjour,
      Je pose ce commentaire ici à défaut de pouvoir le faire ailleurs… Pardonnez moi… mais vous me semblez le plus sachant sur WP sur les pages perso free.
      Sauriez vous si le plugin WP REST API fonctionne sur les pages perso de free ?
      Le plugin est activé, mais l’url http://user.free.fr/blog/wp-json/posts me renvoie une 404 de free…
      Y a t-il une specificité chez Free ? Ce serait dommage, c’est vraiment un super plugin…
      Merci

      1. Bonsoir,
        Apparemment ce plugin tente des accès sortants sur certaines URL.
        A l’heure actuelle, les accès sortants sont interdit sur les pages perso sauf pour quelques URLs importantes.
        Je cite :

        Un certain nombre d’URL « importantes » sont acessibles depuis les scripts PHP (mises à jour WordPress, Dotclear, Drupal, Aksimet, Google reCaptcha, etc.). Une fois la nouvelle version en production, il sera possible de demander la mise en liste blanche de certaines URL pour accès depuis les scripts PHP.

        A lire ici : Migration des serveurs des Pages Perso de Free vers PHP 5.6.8 : Informations techniques
        Donc, il vous restera la possibilité, une fois la version définitive de PHP 5.6 mise en production de proposer d’ouvrir les accès sortants pour ce plugin sur le forum USENET officiel de support des pages perso.

    8. Aleluya,

      Grâce aux premières lignes de cet article je vois enfin le logo de GLPI version 9.0 apparaître sur mon site hébergé chez Free.

      Avant un beau message : « PHP 5.4 required » et après l’ajout de :

      <IfDefine Free>
      php56 1
      </IfDefine>
      

      et même l’upload du .htaccess sécurisé mis à dispo ici, je peux enfin accéder à mon site.

      Merci !

    9. Salut, mon site étant actuellement sous WordPress 3.9.1 php en version5.1.3 j’ai tenté le passage en version 5.6 pour avoir plus de memoire pour mes plugins, mais si je modifie mon .htaccess , j’ai une belle erreur 500, avec mon site indisponible :(
      J’ai beau lire et relire les articles, je ne vois pas ou je faute, une idée svp ?

    10. migration en php 5.6 et mise à jour WP 4.4 dans la foulée… rien à signaler de mon côté, tout s’est bien déroulé !
      j’en profite pour vous remercier de toutes les versions FREE que vous avez pu mettre à disposition, cela m’a été particulièrement utile !
      bien à vous,

      1. bonjour, savez vous si il est obligatoire de mettre WordPress dans le répertoire session, dans ce cas mon url est rallongé url/session/index.php/… ?

      1. C’est parce que votre serveur est perso101-g5.free.fr qui est un des trois serveurs ne disposant pas de la version béta, voir : Historique du déploiement de la nouvelle version
        Je cite

        22/07/2015 : Ouverture de la période de beta-test publique (PHP 5.6 est disponible sur la majorité des serveurs). Les serveurs perso98-g5.free.fr, perso101-g5.free.fr et perso103-g5.free.fr ne disposent pas de la version beta. Si votre compte est hébergé sur l’un de ces serveurs, vous devrez patienter. Les comptes hébergés sur les serveurs perso101-g5.free.fr et perso103-g5.free.fr seront migrés petit à petit sur d’autres serveurs.

        1. J’essaye depuis hier d’installer WP 4.4.2 sur mon ftp mais impossible d’y arriver.
          Voila le message que j’obtiens quand je vais sur mon site.
          J’ai bien crée le .htaccess ainsi que les dossiers tmp et sessions a la racine du serveur mais rien ne fonctionne.

          genesiis.free.fr

          Warning: require_once(/var/www/sda/4/6/genesiis/wp-includes/load.php): failed to open stream: No such file or directory in /var/www/sda/4/6/genesiis/wp-load.php on line 49

          Fatal error: require_once(): Failed opening required ‘/var/www/sda/4/6/genesiis/wp-includes/load.php’ (include_path=’/var/www/sda/4/6/genesiis/include:.:/usr/php5/lib/php’) in /var/www/sda/4/6/genesiis/wp-load.php on line 49

          Avez vous une solution ? :(

          Merci d’avance

          1. Non, désolé, je n’ai pas d’idées.

            • Avez-vous bien dézippé les fichiers et dossiers de WordPress ?
            • Avez-vous vérifié que les fichiers et dossiers ont été effectivement tranféré sur votre FTP ?
    11. hello,
      Je suis occupé de migrer les Sites-blogs de mon épouse (on passe de CMS GUPPY à WP !) et oui on est chez FREE…
      Pas évident lorsque l’on débute sur WP :)
      Encore un GRAND merci à toi pour la rédaction de cet article qui m’a permis de résoudre pas mal de bugs !

      QUESTION : certains thèmes (comme DYAD) demandent le plugin « JetPack »… à l’installation pas de soucis… mais à l’utilisation… il demande le passage du site en HTTPS !!! avez-vous rencontrer ce soucis !?
      bien_sûr j’ai consulter … https://jetpack.com/support/getting-started-with-jetpack/troubleshooting-tips/

      mais bon j’ai pas trouvé l’astuce… oû il a y une autre solution !?

      @+++ MasterSlash

      1. Certains plugins ne fonctionnent pas sur les pages perso de FREE du fait même des limitations de l’hébergement. Il faut donc les essayer un par un. Le HTTPS n’étant pas disponible sur les pages perso, les plugins qui en ont besoin sont donc inutilisables.

        Concernant Jetpack, je ne l’ai pas essayé mais il me semble qu’il est composé de modules différents que l’on peut ou non activer à son choix.

        1. ouinnn…. c’est ce que je craignais :( incompatibilité entre certains plugins ou thèmes de WP et FREE !!! de même comme certaines limitations (comme le HTPPS, la mémoire à 64M maxi, upload à 2Mo, …)

          selon toi… existe-til un site qui centralise les compatibilités des plugins, thèmes entre eux !?

          Merci
          @+++ MasterSlash

          1. Il y a eu une tentative effectué par Rodolphe Marsolier mais ce dernier a fermé son blog. C’est une entreprise longue et fastidieuse puisqu’il existe plus de 45 000 plugins sur le dépôt officiel à ce jour.
            Actuellement, il n’y a pas d’autres solution que de tester les plugins un par un soi-même. Et pour être certain de la pérennité du site, le mieux est d’en installer le minimum.

            1. re… j’essaie de mettre WP sur un autre espace Homepage FREE… ou j’avais déjà fait des tests non concluants à l’époque… j’ai tout effacé l’emplacement :) puis de éinstaller et pas moyen … WP me dit que j’ai une erreur dans la base que je dois réparer avec define(‘WP_ALLOW_REPAIR’, true); dans config.php.. mais bon ça fait pas grand chose… as-tu une idée !?? merci

    12. bonsoir… comme tu le sais… surement :) la mise à jour de WordPress 4.6 vient de soirtir… bien-sûr.. je clique pour l’installer (j’suis bien chez FREE !) et « PAF ! » erreur :

      Fatal error: Call to undefined function wp_mkdir_p() in …/wp-includes/pomo/native.php on line 220

      es-tu au courant ? as-tu déjà une solution !?

      merci à toi
      @+++ MasterSlash

      1. Bonsoir,
        Oui, c’est le hack gettext qui permet d’économiser 4 Mo de mémoire PHP.
        Si en rechargeant la page ce message ne disparait pas, il suffit de commenter l’appel à ce hack qui doit se situer normalement dans le fichier wp-config.php en ajoutant deux slash devant la ligne :

        //require( ABSPATH . '/wp-includes/pomo/native.php');

        Si bien sûr vous avez installé ce hack comme indiqué dans le paragraphe (Optionnel) Utiliser la bibliothèque « gettext » pour réduire la consommation de mémoire PHP

        Ce qui est étonnant, c’est que ce hack fonctionne très bien sur le serveur de test de FREE avec php 5.6.23.

        1. OK :) tout va bieeen… j’explique ma démarche :

          – Oui AVANT j’étais en WP 4.5.3 et j’avais installé le « hack WordPress » pour économiser de la mémoire !
          – suite à ta réponse, j’ai donc mis ce hack en commentaire dans le fichier wp-config.php,
          – puis je suis passé en mise à jour WP 4.6 sans soucis !
          – et je suis revenu sur wp-config.php pour supprimer les //
          – ça fonctionne… de 88% Memory… je suis tombé à 71% :)

          +++ content je suis !!
          merci pour la rapidité de tes réponses !
          @+++ MasterSlash

    13. Bonjour.

      Tout d’abord, merci. Vos directives sont très précieuses et précises et m’ont énormément aidé, aiguillé, pour mettre à jour mon site.

      Cependant, j’avais une petite erreur, concernant le hack gettext. Lorsque j’ajoutais la ligne de code au bout de wp_config.php, j’avais une erreur PHP :

      Warning: Cannot redeclare class MO in /var/www/sda/2/6/…/wp-includes/pomo/native.php on line 242

      Je mets ce commentaire au cas où des personnes aient le même souci, que j’ai réussi à régler en déplaçant la ligne à ajouter pour inclure le fichier native.php. Il suffit de la mettre juste avant ceci :

      /** Réglage des variables de WordPress et de ses fichiers inclus. */

      et non pas à la fin du fichier wp_config.php

      J’espère que ça aidera.

      Cordialement.

    Laisser un commentaire

    Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *